Temporary Service Limitations

Minor Incident Business Telephony SIP Trunk Cloud Telephony Infrastructure Cloud Telephony AppSuite
2026-05-12 08:05 CEST · 3 hours, 22 minutes

Updates

Monitoring

The implemented mitigation measures are showing positive results and services are currently stabilizing.
Our teams continue to actively monitor the NFON platform to ensure service availability and performance. Further updates will be provided if necessary.

May 12, 2026 · 08:53 CEST
Update

Our technical teams continue to work on resolving the ongoing platform issues.
While stabilization efforts are showing initial improvements, some users may still experience intermittent service limitations, login issues, or degraded performance.
We remain focused on fully restoring normal operations and will provide further updates as more information becomes available.

May 12, 2026 · 08:38 CEST
Investigating

We are currently experiencing service limitations and delays affecting parts of the NFON platform.
Our technical teams are working with the highest priority to identify the root cause, stabilize the systems, and restore normal operations as quickly as possible.
Impacted services may include intermittent availability issues, login problems, or degraded platform performance.

May 12, 2026 · 08:05 CEST

← Back