Temporary Disruptions in Outbound Calls – Italy

Minor Incident Carrier Italy
2025-07-24 11:43 CEST · 1 hour, 48 minutes

Updates

Resolved

The affected Italian partner carrier could resolve the issue. All calls to international destinations and premium-rate numbers should now work without any issues.

July 24, 2025 · 13:28 CEST
Issue

Some Italian customers may currently be experiencing issues with calls to international destinations and premium-rate numbers. The affected Italian partner carrier is already investigating the matter

July 24, 2025 · 11:43 CEST

← Back